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Analyzing and Visualizing Data with Microsoft Excel 

Exam A 

QUESTION 1 

Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might 

meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution. 
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After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen. 

You have an Excel workbook that contains a table named Table1. A sample of the data in Table1 is shown in the following table. 

 

You need to create a PivotTable in PowerPivot as shown in the exhibit. (Click the Exhibit button.) 
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Solution: You create a hierarchy named Products that contains ProductCategory, ProductSubCategory, and ProductName. You add a PivotTable. You drag 

Products to the Rows field. You drag Price to the Values field.  

Does this meet the goal? 
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A. Yes 

B. No 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 2 

Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might 

meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution. 

After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen. 
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You have an Excel workbook that contains a table named Table1. A sample of the data in Table1 is shown in the following table. 
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You need to create a PivotTable in PowerPivot as shown in the exhibit. (Click the Exhibit button.) 
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Solution: You add a PivotTable. You drag ProductCategory, ProductSubCategory, and ProductName to the Rows field. You drag Price to the Values field.  

Does this meet the goal? 

A. Yes 
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B. No 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 3 

Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might 

meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution. 

After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen. 

You have a Power Pivot model that contains the following tables. 

 

There is a relationship between Products and ProductCategory. 

You need to create a hierarchy in Products that contains ProductCategoryName and ProductName. 

Solution: You create a measure that uses the USERELATIONSHIP DAX function. 

Does this meet the goal? 

A. Yes 

B. No 
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Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 4 

Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might 

meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution. 

After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen. 

You have a Power Pivot model that contains the following tables. 

 

There is a relationship between Products and ProductCategory. 

You need to create a hierarchy in Products that contains ProductCategoryName and 

ProductName. Solution: You create a calculated column that uses the RELATED DAX function 

Does this meet the goal? 

A. Yes 

B. No 

Correct Answer: A 
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Section: (none) 

Explanation 

Explanation/Reference: 

References: 

https://www.mssqltips.com/sqlservertip/2900/creating-hierarchies-in-powerpivot-for-excel/ https://msdn.microsoft.com/en-
us/library/ee634202.aspx 

QUESTION 5 

Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might 

meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution. 

After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen. 

You have a Power Pivot model that contains the following tables. 

 

There is a relationship between Products and ProductCategory. 

You need to create a hierarchy in Products that contains ProductCategoryName and 

ProductName. Solution: You create a measure that uses the ISCROSSFILTERED DAX function 

Does this meet the goal? 

A. Yes 

B. No 
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Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 6 

Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each 

question presents a different goal and answer choices, but the text of the scenario is the same in each question in this series. 

Start of repeated scenario. 

You have six workbook queries that each extracts a table from a Microsoft Azure SQL database. The tables are loaded to the data model, but the data is not 

loaded to any worksheets. The data model is shown in the Data Model exhibit. (Click the Exhibit button.) Exhibit:  
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Your company has 100 product subcategories and more than 10,000 products. 

End of repeated scenario. 

You have a PivotChart that uses Manufacturer as the axis and the sum of SalesAmount as the values. 

You need to ensure that only the top 10 manufacturers appear in the chart. 

What should you do? 

A. Configure the Value Filters 

B. Summarize the SaleAmount field by Max 

C. Change the format of the SalesAmount field 

D. Create a calculated column 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://www.exceldashboardtemplates.com/how-to-easily-make-a-dynamic-pivottable-pie-chart-for-the-top-x-values/ 

QUESTION 7 

You have a table that contains data relating to exam candidates and their associated exam scores. 

You need to visualize the exam data by separating the data into quartiles. The visualization must display the mean score and must identify any outliers. 

Which type of chart should you use? 

A. line 

B. pie 

C. box and whisker 

D. histogram 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 
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References: https://support.office.com/en-us/article/create-a-box-and-whisker-chart-62f4219f-db4b-4754-aca8-4743f6190f0d 

QUESTION 8 

You have an Excel spreadsheet that contains a PivotChart. 

You install Microsoft Power BI Publisher for Excel. 

You need to add a tile for the PivotChart to a Power BI dashboard. 

What should you do? 

A. From powerbi.com, click Get apps 

B. From powerbi.com, upload the Excel workbook 

C. From the File menu in Excel, click Publish 

D. From the Power BI tab in Excel, click Pin 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://docs.microsoft.com/en-us/power-bi/service-publish-from-excel 

QUESTION 9 

You have an Excel workbook that contains two tables named User and Activity. 

You plan to publish the workbook to the Power BI service. 

Users will use Q&A in the Power BI service to perform natural language queries. 

You need to ensure that the users can query the term employee and receive results from the User table. 

What should you do before you publish to Power BI? 

A. From PowerPivot Settings, modify the Language options 

B. From PowerPivot Settings, modify the Categorization options 

C. From the Power Pivot model, edit the Synonyms 

D. From Workbook Connections, add a connection 
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Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

References: http://blog.pragmaticworks.com/optimizing-power-bi-qa-with-synonyms-phrasing-using-cloud-modeling 

QUESTION 10 

You open C:\Data\Data.xlsx in Excel. 

When you attempt to publish the file to Microsoft Power BI, you receive the following error message: “We couldn’t publish to Power BI. Make sure your workbook is 
saved as an Excel file (.xlsx or .xlsm) and is not password protected.” 

You need to ensure that you can publish the file to Power BI. 

What should you do first? 

A. Decrypt the workbook 

B. Copy the file to a network share 

C. Add a digital signature to the workbook 

D. Disable iterative calculation for the workbook 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://docs.microsoft.com/en-us/power-bi/service-publish-from-excel 

QUESTION 11 

Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each 

question presents a different goal and answer choices, but the text of the scenario is the same in each question in this series. 

Start of repeated scenario. 

You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A 
sample of the data is shown in the Data Sample exhibit. (Click the Exhibit button.) 
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Data Sample exhibit: 
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The data model is shown in the Data Model exhibit. (Click the Exhibit button.) 
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The tables in the model contain the following data: 

 DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or 

revenue are recorded for that day. Total Hours and Total Revenue column. 

 Workshops have a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always 

Firstname Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.  

RepairTypes has a list of all the repair types  Dates has a list of dates from 2015 to 2018 

End of repeated scenario. 

You create a measure named Average Revenue Per Hour that calculates the average revenue per hour. 

You need to populate a cell in a worksheet to display the Average Revenue Per Hour where Repair Type is Engine. 

Which Excel formula should you use? 

A. =CUBEMEMBER(“ThisWorkbookDataModel”, “[DailyRepairs]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, 

“[Dimensions]. [Repair Type]. [Engine]”)) 

B. =CUBEVALUE(“ThisWorkbookDataModel”, “[Measures]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, 
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“[Dimensions]. [Repair Type]. [Engine]”)) 

C. =CUBEMEMBER(“ThisWorkbookDataModel”, “[DailyRepairs]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, 

“[RepairTypes]. [Repair Type]. [Engine]”)) 

D. =CUBEVALUE(“ThisWorkbookDataModel”, “[Measures]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, 

“[RepairTypes]. [Repair Type]. [Engine]”)) 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

References: 

https://support.office.com/en-us/article/cubevalue-function-8733da24-26d1-4e34-9b3a-84a8f00dcbe0 

https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_cube_cubemember_function.htm 

QUESTION 12 

You have the Excel worksheet shown in the exhibit. (Click the Exhibit button.) 

Exhibit:  
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You need to transform the data by using Query Editor. 

What should you do first? 

A. From the Data tab, click Flash Fill 

B. From the Insert tab, click Store 

C. From the Data tab, click From Table/Range 
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D. From the Data tab, click Consolidate 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/unified-get-transform-experience-ad78befd-eb1c-4ea7-a55d-79d1d67cf9b3 

QUESTION 13 

You have an Excel workbook that has the following two workbook queries: 

 A query named Consultants that retrieves a table named Consultants_Contact from a Microsoft SQL Server database 

 A query named Employees that retrieves a table named Employee_Contact from a Microsoft Azure SQL database 

Both tables have the same columns. 

You need to combine all the data from Consultants and Employees into one table. 

Which command should you use? 

A. Append Queries 

B. Combine Binaries 

C. Transpose 

D. Merge Queries 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/merge-queries-power-query-fd157620-5470-4c0f-b132-7ca2616d17f9 

QUESTION 14 

You have multiple workbook queries that load data from tables in Microsoft Azure SQL Database to a Power Pivot data model.  

You discover that new rows were added to the tables in Azure SQL Database. 

You need to ensure that the workbook has the new data. 
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What should you do? 

A. From the Data tab, click Refresh All 

B. From the Power Pivot tab, click Update All 

C. Close and open the workbook 

D. Select a cell in the worksheet and press F5 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/refresh-an-external-data-connection-in-excel-2016-for-windows-1524175f-777a-48fc-8fc7-c8514b984440 

QUESTION 15 

You have an Excel workbook query that loads data to a worksheet and the data model. 

You need to ensure that the data is refreshed whenever you open the workbook. 

What should you do? 

A. From the File tab, click Options, and then modify the General options 

B. From the Power Pivot model, modify the Table Behavior setting 

C. From the File tab, click Options, and then modify the Data options 

D. Run the Data tab, click Queries & Connections, and then edit the properties of the query 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/refresh-connected-imported-data-e76a38b0-e2e1-400b-9f2f-c87b9b18c092 

QUESTION 16 

You have two queries named Client and Invoices. A sample of Client is shown in the following table. 
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A sample of Invoices is shown in the following table. 

 

You need to create a new table that has the following information. 
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Which join kind should you use? 

A. Left Outer 

B. Left Anti 

C. Inner 

D. Right Anti 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 17 

You have a workbook query that loads the following table 
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You pivot the table on the Key column by using Value as the values column, and you receive the results shown in the following table. 

 

You need to ensure that the data appears as shown in the following table. 
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What should you do? 

A. Change the Aggregate Value Function of the pivot 

B. Change the Data Type of the Value column 

C. Select the ID column, and then click Unpivot Columns 

D. Delete the Pivoted Column step. Select the Key column, and then click Unpivot Columns 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/unpivot-columns-power-query-0f7bad4b-9ea1-49c1-9d95-f588221c7098 

QUESTION 18 

You need to create a PivotChart that has a filter as shown in the following exhibit. 
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What should you do first? 

A. From the model, create a measure 

B. From Query Editor, create a function 

C. From the model, create a hierarchy 

D. From Query Editor, create a parameter 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/measures-in-power-pivot-86484821-a324-4da3-803b-82fd2e5033f4 

QUESTION 19 

You have the following table. 
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You plan to use [Month Name] as the axis in a PivotChart. 

You need to ensure that whenever [Month Name] is used in a chart, the months are displayed chronologically by default.  

What should you do? 

A. Add a calculated column named [ID] that uses the [Month Name]&[Month Number] DAX formula 

B. Change the Data Type of [Month Name] to Date 

C. Sort the [Month Number] column by [Month Name] 

D. Sort the [Month Name] column by [Month Number] 
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Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://gasperkamensek.wordpress.com/2013/04/16/sorting-months-chronologically-and-not-alphabetically-in-a-pivot-table-report-based-on-

powerpivot-data/ 

QUESTION 20 

You have a table in a Power Pivot model that is loaded from a Microsoft SQL Server database. 

The source table has four columns named ID, Price, Quantity, and Total. Total is derived by multiplying Price and Quantity. ID is a unique row identifier.  

You need to minimize the amount of memory used to load the model. The solution must ensure that you can create visualizations based on Price, Quantity, and 

Total. 

What should you do? 

A. Replace the Total column by using a measure 

B. Replace the Total column by using a calculated column 

C. From Query Editor, remove duplicate rows from the table 

D. Move the Total column to a lookup table 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

References: https://support.office.com/en-us/article/create-a-memory-efficient-data-model-using-excel-and-the-power-pivot-add-in-951c73a9-21c4-46ab-
9f5e14a2833b6a70#__toc373850959 
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